Как самому обновить версию QUIK, если у брокера еще не выложено обновление?

Речь о большом терминале QUIK для Windows.

Часто задаётся вопрос: вышла новая версия терминала QUIK, с полезным функционалом. Хотелось бы её попробовать, но при подключении к серверу брокера никаких обновлений не предлагается, когда брокер выложит у себя новую версию — совершенно не понятно. Как бы обновиться на новую версию?

Небольшое вступление

На самом деле обновлять терминал достаточно просто. Надо лишь помнить следующее:

  • Главное в этом деле — обязательно перед обновлением сделать резервную копию! Для этого достаточно, закрыв терминал, просто скопировать все файлы в отдельную папку. Это позволит совершенно точно без каких-либо проблем вернуться к старой версии, если в новой обнаружится какая-то критичная проблема.
  • Скорее всего, после ручного обновления самого терминала необходимо будет еще обновить плагины, которые находятся в отдельных архивах, т.к. являются «дополнениями»; про это в конце заметки. Плагины в QUIK обычно отвечают за разные доп. возможности: ввод/вывод средств, подача специфических поручений именно у вашего брокера, аналитика на срочном рынке и т.д.
  • У некоторых брокеров терминал чуть-чуть специфичный, с небольшими изменения внешнего вида или дополнительными расчётными параметрами, однако при этом стандартный терминал (так условно его назовём), лежащий в виде обновлений, совершенно корректно будет работать с любым брокером.
  • Иногда для корректной работы новой версии терминала QUIK требуется обновление серверной части брокером. В этом случае до тех пор, пока брокер не обновит сервер QUIK, воспользоваться новой версией терминала не удастся. В этом случае при подключении новой версией увидим сообщений «Неправильная версия протокола». Придётся откатиться на сохранённую предыдущую версию (вы ведь сохранили её?!) и задать брокеру вопрос «когда же».

Собственно обновление

Первым делом требуется закрыть терминал и сделать резервную копию всех файлов. Резервная копия делается просто: при закрытом терминале копируем всю папку с терминалом QUIK в отдельное место. В случае неожиданных проблем мы всегда можем восстановить предыдущую версию терминала или вовсе пользоваться старой и новой версией поочерёдно.

Теперь идём на «секретный» ftp с обновлениями (это, как видите, домен компании Arqa, так что всё официально), там выбираем папку с нужной версией и из неё скачиваем архив с обновлением. Например, для версии 7.4 это будут следующие пути:

После завершения загрузки распаковываем файлы из архива и все их переписываем поверх нашего старого терминала. (Еще раз: резервная копия у нас есть? точно, не забылось?)

Теперь запускаем обновлённый терминал и изучаем новые возможности! ну или хотя бы радуемся исправлению старых багов 😉

После запуска новой версии в окне сообщений ошибка: «StratVolat.dll: Загружаемый модуль не совместим с данной версией клиентского места» или другая dll

Названия dll-файлов могут быть различными, в том числе подобных сообщений может быть несколько. Эти сообщения говорят о том, что требуется еще обновить соответствующие плагины. Вообще говоря, терминал будет работать и так, но некоторые специфичные функции, обеспечиваемые плагинами, будут недоступны.

В зависимости от указанного в сообщении имени dll-файла (см. список соответствий ниже) скачиваем из той же папки на ftp, где лежит обновление терминала,  соответствующие архивы с обновлением плагинов:

  • AutoFollow.dll — AutoFollow_xxx_upd.zip — модуль Автоследования
  • BTrading.dll — BasketTrading_xxx_upd.zip — модуль Basket Trading
  • Colibri.dll — Colibri_xxx_upd.zip — модуль риск-менеджера «CoLibri»
  • CoLibriFM.dll — ColibriFM_xxx_upd.zip — модуль риск-менеджера «CoLibri FM»
  • CoLibriFX.dll — ColibriFX_xxx_upd.zip — модуль риск-менеджера «CoLibri FX»
  • FxPlugin.dll — FXPlugin_xxx_upd.zip — модуль FX Plugin
  • InstrClient.dll — Instructions_xxx_upd.zip — модуль неторговых поручений
  • Reports.dll — Reports_xxx_upd.zip — модуль формирования отчетов
  • StratVolat.dll — StratVolat_xxx_upd.zip — модуль опционной аналитики
  • TM.dll — TrustManager_xxx_upd.zip — модуль доверительного управляющего

Обновляем только те плагины, которые требуют обновления. Перезапускаем терминал (чтобы новые плагины включились в работу) и наслаждаемся новыми версиями 😉

Всем удачной торговли!

Print Friendly, PDF & Email
Запись опубликована в рубрике Большой QUIK с метками , . Добавьте в закладки постоянную ссылку.

9 комментариев: Как самому обновить версию QUIK, если у брокера еще не выложено обновление?

  1. Торговец говорит:

    На 7.2 версию также можно обновиться? у мня сейчас 7.0 установлена.

  2. Алексей говорит:

    Благодаря Вашей публикации я перешел с версии 7.0.4.10 на 7.4.0.79 за 10минут.
    Но как сказал Владимир Ильич Ульянов(Ленин) — Мы пошли другим путем!
    1. Скачал архив — quik_7.4.0_upd.zip по адресу — ftp://ftp.quik.ru/public/updates/7.4/
    2. Распаковал архив архиватором в одноименную папку — quik_7.4.0_upd и открыл в отдельном свёрнутом окне.
    Примечание: дальнейшие действия проводились при открытом терминале.
    3. Нашёл папку с файлами установленного терминала и также открыл в отдельном свёрнутом окне.В этом же окне выбрал в интерфейсе вкладку — Вид, и установил галочку «скрытые элементы».
    4. Перешёл на вкладку — Главная, воспользовавшись функцией — Выделить всё, выделил все папки и файлы.
    5. Захватил выделенные файлы ЛКМ (левой кнопкой мыши) и перетащил в открытое окно quik_7.4.0_upd.
    Важно: При перетаскивании — стрелку направлять в область интерфейса дабы случайно не скопировать выделенные файлы в одну из папок данного окна.
    6. При копировании появляется окно, предлагающее три варианта:
    1.заменить файлы 2.пропустить файлы 3. оставить оба
    Выбрал 2 вариант-пропустить файлы.
    7. В интерфейсе обновлённого окна нажал кнопку «стрелка вверх»
    8. Перешёл на вкладку — Главная,выделил обновлённую папку и воспользовавшись функцией — переместить в, переместил в нужное место (я переместил в папку где находится папка с рабочим терминалом)
    9. Снова открыл обновлённую папку(в моём случае — quik_7.4.0_upd),выделил ЛКМ файл info (тип-приложение) затем ПКМ открыл подменю и выбрал — закрепить на панели задач.
    Закрыл все папки,закрыл рабочий терминал и запустил через панель задач обновлённую версию терминала. Работает и нет сообщений о несовместимости модулей и плагинов.
    p.s. Фондовый рынок,брокер «Сбербанк России»
    И если что-то не так,то можно перейти к выше описанной публикации или запустить старую версию.

    • iQuik.ru говорит:

      Спасибо вам за подробное описание!
      Не всё я лично понял (главное, зачем проделывать обновление при запущенном терминале?!), но для кого-то вероятно ваша инструкция будет понятнее.

      • Алексей говорит:

        Просто когда я скачивал версию quik_7.4.0_upd.zip, рабочий терминал с версией 7.0.4.10 был запущен, а так как после остановки и повторном запуске необходимо вводить пароль и пин-код я решил с экономить время и произвести все вышеуказанные действия при запущенном терминале. Для этого и указал о последовательности своих действий.
        Сегодня(12.10.16) перешел с версии 7.4 на версию 7.5 без запуска терминала……Работает.
        Особое Внимание к п.5 .Чтобы при перетаскивании указывалось копирование,а не перемещение!!! Чтобы не нарушить БЕЗВОЗВРАТНО папку с действующим терминалом.

    • Алексей говорит:

      Особое Внимание к п.5 .Чтобы при перетаскивании указывалось копирование,а не перемещение!!! Чтобы не нарушить БЕЗВОЗВРАТНО папку с действующим терминалом.

  3. Ilia говорит:

    Не понял как dll обновить? Их нет в папке с обновлением quik 7.12

Добавить комментарий